danmaksim

I am using VS2017 as required for UE4 v4.16 and later.  Steps to reproduce:
1. Download latest release branch of unreal engine from github (4.16.1)
2. Build engine and create new, empty UE4 project
3. Add C++ class via UE4 editor
4. Packaging project works OK. (via file > Package Project > Windows > Windows 64-bit)
5. Add VoxelFarm plugin to UE4
6. Packaging project now fails.  Output:

UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: VoxelFarmPlugin.generated.cpp
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: V:\Trunk\Launcher\Epic Games\Unreal Projects\mt416\Plugins\VoxelFarmPlugin\Source\VoxelFarmPlugin\Public\VoxelFarmWorldActor.h(429): warning C4996: 'FBox::FBox': Use ForceInit constructor instead. Please update your code to the new API before upgrading to the next release, otherwise your project will no longer compile.
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: v:\trunk\git\4_16_1\engine\source\runtime\core\public\Math/Box.h(37): note: see declaration of 'FBox::FBox'
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: V:\Trunk\Launcher\Epic Games\Unreal Projects\mt416\Plugins\VoxelFarmPlugin\Source\VoxelFarmPlugin\Private\VoxelFarmWorldActor.cpp(2291): error C2660: 'VoxelFarm::IO::CVoxelFileDB::init': function does not take 2 arguments
UATHelper: Packaging (Windows (64-bit)): UnrealBuildTool: ERROR: UBT ERROR: Failed to produce item: V:\Trunk\Launcher\Epic Games\Unreal Projects\mt416\Plugins\VoxelFarmPlugin\Binaries\Win64\mt416-VoxelFarmPlugin.lib

0 0
voxelfarmtorres
We are currently looking at this. We will get back to you a bit later today.
0 0
voxelfarmtorres
In VoxelFarmWorldActor.cpp line 2288 there is a compiler conditional that branches the DB initialization. Please replace the whole construct by just:

voxelDBR->init(dataDir);

The init() variant that takes a second parameter as boolean was removed.
 
0 0
danmaksim

This works, I can now package and run the project.  Thanks!

However, the voxelfarm terrain doesn't appear when I run the packaged game.  It still appears in editor/simulate/play-in-editor.

I am calling the "Set Block Line of Sight" node and "Set ClipMapView Focus" node in the level blueprint on the voxelFarmWorldActor.

Any ideas on what I may be missing?

0 0
voxelfarmtorres
If there are no errors loading and you still do not see terrain, it is likely because the folder that contains the Voxel Farm bundle was not included in the build. This is located at "Content\VoxelProjects\<YourBundleName". To package this folder in your build, you must list it in Project Settings > Packaging in the section for "Additional Non-asset Directories to Copy":

3325345.png 
0 0
danmaksim

This works, VoxelFarm terrain now appears in my packaged build.

I still noticed that foliage (placed via a "Planting Rule" in the VoxelFarm bundle) wasn't appearing, but after placing the staticMesh used by the planting rule in an "additional asset directories to cook" folder, it appears.

Thanks for the speedy support!  I'm very pleased with VoxelFarm so far, 10/10 would voxelize again.  =]

PS - any idea when an updated UE4 plugin with more blueprint-exposed functionality might drop?

0 0
voxelfarmtorres
Thanks! We are getting close to a new UE release. This will be a major update, including much better performance, improved physics, and nav-mesh support. Unfortunately, the blueprint interface will remain the same for this drop.
0 0