Koniferus
Hello! Liking what I see so far and I'm wanting to dig as deep as possible during my trial month, so that I know if this is something I want to commit to my ongoing project.

I've got it running in UE4 and I'm starting to get the swing of things.

I've got a few questions though, things that are somewhat getting in my way:

  1. If I enable "Start with Tick Enabled" It seems to be rendering the terrain way higher up than when I hit play. If I have my dude standing on the grass in the preview pane, then I hit play, the ground is suddenly 40k units lower than what it was and my guy falls for a really long time and it often crashes with this enabled as well.
  2. How would I go about turning down the amount of foliage that's being placed on the map? When I'm flying around in the preview window without playing or simulating, it runs amazingly well, I'm guessing because of the lack of foliage spawning.
  3. Has anyone found a fix for that small hang each time things pop-in? I'm running at 80-100FPS, then if I walk far enough to make more foliage/terrain spawn, I drop down to 1-2FPS for a few seconds.
  4. Are any of the perameters from C++ exposed in blueprints and where can I find them if so? I'm not seeing much in the BP_VoxelFarmActor but I'm probably just too n00b to know where to look.

Any help is greatly appreciated, I'm looking forward to using this and it seriously fits my game's overall needs from what I can tell.
0 0
voxelfarmtorres
I have dispatched questions (1) and (4) to the devs. I'll update this thread as soon as I get answers. About your other questions:

2. Planting rules have a density parameter, which ranges from 0 to 1. The closer density is to zero, the fewer instances you will have.

3. We do not experience such performance hiccups. Do you get these on the compiled demos as well?
0 0
Koniferus
Thanks!!

For 3 - I'll package my game tonight and give it a shot. I need some more RAM for sure so I won't be surprised if it's a resource issue on my end.

Another Q: I made a new terrain using the wizard in voxel studio and used the export to UE4 button to send it to a new folder in my content directory. I see an option in the BP_VoxelFarmActor to chose a .pak file to load, but my exported bundle from voxel studio has no .pak files. I also can't find the .pak file that it's set to by default.

Am I missing something when it comes to importing the new terrain?
0 0
Koniferus
Question 1 can be disregarded. I re-installed and made a new copy of the demo project and it works fine by default. I must have messed something up while experimenting.

Thanks again for the answers thus far!
0 0