hwang
Hi all!

I just imported a fresh demo level (ToonTerrain) to Unreal 4.22, added a character, and moved around noticing that the terrain physics is not updating properly according to the position of the main character.
Specifically, after the character moves past a certain threshold, it simply falls into void.

I read the documentation of Enabling Voxel Physics (https://www.voxelfarm.com/doc.html?enabling-voxel-physics) and accordingly, the collision should automatically update along with the terrain LOD (can be changed through the paramter Cell Physics Max LOD). But increasing the LOD parameter simply increased the threshold before free falling, and it doesn't change the fact that colliders did not update/move at all after game started.

All I did was importing and moving around, and I didn't do any adjustments to the VoxelFarmActor. Did I miss something? What settings needs to be done in order to get the collision update properly?

Thanks in advance!
0 0
voxelfarmtorres
This could be caused by not calling the Set Clipmap Focus to pass the new character positions. Are you performing this step:

https://www.voxelfarm.com/doc.html?controlling-scene-focus-2
0 0
hwang
Yes, I followed that Controlling-scene-focus as well. The problem turned out to be that I moved a bit too fast that the collision updating couldn't catch up.

Is there a way to force finishing generating the collision before player enters a chunk?
The framerate would defenitely drop (depending on the hardware of course), but I mean, that seems like the only way to prevent players from entering a terrain without colliders, and thus free falling into the void.
0 0