Morcrist
Can anybody explain why all the terrain textures would be greyed out after switching from Gamma to Linear? More importantly, can anybody explain how to FIX it?

[biggrin]


screenshot010.jpg 
0 0
Morcrist
I apologize. I forgot to Search before posting. Please feel free to delete this.

Here is the pertinent information that should result in a fix. I can followup if this thread is not-deleted once I get it working. I have to go to bed right now. [tongue]

https://forums.voxelfarm.com/post/linear-color-space-8166308?highlight=linear&pid=1292755726
0 0
Eugeny
This solution didn't work for me.
It seems that system changed since then. Now all atlases are saved in Voxel Farm Unity Plugin/Resources/Cache/. And they are always with ColorSpace = 1.
0 0
Morcrist
Yeah. Diley, please help. I tried to implement the change to the only call in the entire .cs project that I could find for Texture2D, and it didn't do anything.

In voxelfarm_bundleMaterialHelper.cs, under GenerateAtlasMaterialProperties() at line 480:

 Texture2D texture = new Texture2D(
            propertiesCount,
            materialsCount,
            TextureFormat.RGBA32,
            true);

It was originally false. Changed to true, it did nothing. I even deleted the entire cache folder, deleted my entire terrain bundle, and re-exported from Voxel Studio. Nothing. Still all grey everywhere.

This is pretty game breaking. Am I missing something obvious (again) or does something else need to happen for this to work properly?

Thanks in advance for any help.
0 0
Morcrist
Oh my gosh. Could it really be this simple?

I don't have time to actually revert things and test this out properly, so maybe Diley can offer some input...but after making the single change to voxelfarm_bundleMaterialHelper.cs that I detailed above I did the following and it instantly changed the grey terrain to textured:

1) in Unity, in the Project view, find Voxel Farm Unity Plugin->Resources->Cache->v2->PROJECT_NAME

2) select the atlasProperties_Texture

3) uncheck sRGB

PROJECT_NAME is the folder in which Voxel Studio placed my exported terrain bundle.

Poof! Instant fix. This was after reading:

https://docs.unity3d.com/Manual/LinearRendering-LinearTextures.html

So yeah. Awesome.
0 0
Eugeny
Works perfectly, thank you!
0 0