FreemanCIT
Hi, 

I just begun the evalution period of Voxel Farm 3. I am looking for using it to create content for UE4, and I have a few question: I ran the UE4 example, which are working fine, but I see that voxel farm world is only rendered during play.

In this state, it is not possible to create an actual game world, because it is impossible to place gameplay element or decoration in UE4 in relation to the world.

Can I have some information about the status of the UE4 integration of VF3?

Rgards,
F.
1 0
voxelfarmtorres
We will ask the devs about this.

Our understanding is it is already possible with the version you have, but requires a recompile after setting some #defines. I will update this post as soon as I get a confirmation about this from the devs.
0 0
FreemanCIT
Thank you. 

I checked the code and I see what you mean. I'll wait for your direction to test.
Regards,
0 0
FreemanCIT
Ok, could not wait, so I dug in the code. I fear that your answer will be that a couple of defines wont be enough.

There is no Editor module setup in the UE4 example. There is some code designed to work in the frame of a specific editor module, but the module is not setup, and the UnrealVoxelFarmEditor.targets is pointing to the runtime module. The modification may be simple to create an editor module, but I have not enough skill to try the integration myself.

So is there any plan to release in the future an update of VF3 with an editor module of VF to allow the combination of VFActor and other UE4 actors and feature ? 

Regards,







0 0
voxelfarmtorres
We are on it, this definitively a top priority. I did not get a conclusive answer from the devs yet. Again, our knowledge is this was either very close to finished, or already in.
0 0
FreemanCIT
Thank you for your answer.

I'll keep watching your progress.
Regards,
0 0
voxelfarmtorres
We have confirmed this is possible with the version you currently have:

pie.jpg 
Please follow these steps:

  1. Open blueprint content/voxelfarm/bp_voxelfarmactor
  2. In the Details panel, Actor Tick section, check "Start with Tick Enabled"
  3. In the Viewport tab click on the left-topmost arrow dropdown menu to display the "Preview Viewport Options"
  4. Check "Realtime" in Preview Viewport Options
  5. Close Unreal editor and start it again
1 0
FreemanCIT
it works indeed ! 

Thank you.

0 0