Webbrowser
Heya!

I noticed some discrepancies between the renderer of Voxel Studio and the renderer used within the SDK Bundle sample. Terrain has a different height in Voxel Studio, and it looks more flat (and sometimes even different colours) when rendered in the Bundle sample.
Is there any way to ensure that they are rendered using the same code?

Thanks in advance!
Webbrowser
PRO user
0 0
voxelfarmtorres
You should see the same, provided you have placed the camera in the same location.

Voxel Studio uses the same version of the Voxel Farm components you find in the SDK. is also the case with the Unity and UE4 plugins, which match the terrain you see in Voxel Studio. You can verify this quickly using the default bundle in the SDK (the desert scene with the tower ruin).
0 0
Webbrowser

Thanks for your reply!

 

I got hopeful when you mentioned I could use UE4 and Unity to see the same scene, and tried it out. Materials didn't show in Unity for some reason, but UE4 showed a different scene than Voxel Studio did?? The FBX export did show me what I was expecting to see, but only from a certain position so I can't use that to show the world in-game 🙁

I'd be happy to share screens or anything if that'd help with figuring this out... Spending a thousand on this and then it not working is kind of annoying to say the least... Especially if you combine it with the amount of time spent on making the scene. (If you prefer a different method of communication outside of the forums which is hopefully faster, that would work too)

UE4, Wrong:
Untitled2.png  Voxel Studio: CorrectUntitled3.png  FBX: Correct but too smallUntitled4.png 

0 0
Webbrowser
My current guess is that it’s the export feature not taking some data along. Given that the renderer is (apparently) identical, and the fbx does give the correct result, the only thing that remains is the base data?
i modified my scene by changing the parameters such as elevation height of the scene to values ranging from -500 to 12000. Those values being gone might explain why the render is different?
just guessing here by the way 🙁
0 0
Webbrowser
Did some more testing and found that optimising the mesh causes a very weird visual effect in Voxel Studio.
Half of the scene is wrong, and half of the scene is right. Moving around in the scene causes the voxels that are in LOD0 and LOD1 to be shown correctly once more, and moving away makes them wrong again?

Untitled.png  Untitled2.png 
I tried changing the vertical shift and such to more normal values (ranging from 0 to 500 instead of from -400 to 11000), and the issue is still caused. I'm running short on a deadline here... Is there any way we can fix this? Perhaps be able to make a bundle without optimising first?
0 0
voxelfarmtorres
Can you provide what are the camera coordinates? If you go negative the behavior is undefined. You need to operate in positive space and place your content with enough margins.
0 0
Webbrowser

The coordinates of the last image are:

X: 25573319.713234

Y: 12903.634692

Z: 24766231.391935

 

On a terrain with a max elevation of 55000.

Not sure what you mean with have enough margins in your content? I used a generated world and then modified parameters until it fit what I wanted it to be.

0 0