namrog84
I am trying to learn more about the included SDK examples, and in this attempt. I was trying to run the different SDK\bin executables.

Some of them crash instantly.

e.g. VoxelFarmDemoSimple_*.exe
Tried both x86 and x64, as well as debug variations.

It just reports it has stopped working. Gives no additional information.


If I try to launch with debugger attached.

"Exception thrown at 0x00007FF67AB5EB3C in VoxelFarmDemoSimple_debug_x64.exe: 0xC0000005: Access violation reading location 0x0000000000000000."

It appears like there is some kind of null value in a place it shouldn't be.

CallStack with pdb loaded.
VoxelFarmDemoSimple_debug_x64.exe!VoxelFarm::CCellData::processMesh(VoxelFarm::CClipmapView * clipmapView, VoxelFarm::CMaterialLibrary * materialLibrary, VoxelFarm::CBillboardCache * billboardCache, VoxelFarm::CCellData::ThreadContext * tc, VoxelFarm::StatTracker[51] * stats) Line 1172 C++
VoxelFarmDemoSimple_debug_x64.exe!VoxelFarm::contourCellDataMCA(VoxelFarm::ContourThreadContext * tc, VoxelFarm::CClipmapView * clipmapView, VoxelFarm::CMaterialLibrary * materialLibrary, VoxelFarm::CCellData * cellData, VoxelFarm::CBillboardCache * billboardCache, VoxelFarm::CCellData::ThreadContext * cellDataThreadContext, bool compress, VoxelFarm::StatTracker[51] * stats, bool compressOnlyBoundaries) Line 1674 C++
VoxelFarmDemoSimple_debug_x64.exe!main(int argc, char * * argv) Line 115 C++
[External Code]


I can reliably have these crash if you'd like more information. I can also see some locals. I'm not sure which thing is relevant here as I can't see the above address. The closest thing to it is the __vfptr and its 2 elements. But they are at address 0x7ff67ab4354e which is just shy of the 0x7ff67ab5eb3c.


Somewhere in ProcessMesh, which I believe I don't have access too as its part of the compiled dll? 
Possibly just passed bad data from sample? I'm not sure. 


I haven't yet tried compiling the samples myself to see if it behaves there as well.
0 0
voxelfarmtorres
Thanks for the report. We are aware of this issue with the VoxelFarmDemoSimple project. The demo code needs to be updated to reflect a recent change. It will be corrected in the next update.

There are no known issues for the other demos. We just tried the last distribution and they are working. Please note the x86 demos will not run because the DLLs in the bin folder are for x64. In order to run them, you need to copy the DLLs in bin\x86 into bin. Running an x86 process with x64 DLLs will produce a crash-like error, but this is expected:

x86.png 

If you have any other crash than the VoxelFarmDemoSimple one, it would help us greatly if you provide the information for it.
0 0
namrog84
Thanks. I hadn't fully realized the x86 related issue.

Looking at the 13 or so _x64 non debug build variations: 


* demo_bundled_x64.exe launches and shows the VF logo and some keyboard commands.  I let it sit here for several minutes and nothing happens. F1 does nothing for 'help'. I'd expect to see the green progress bar in bottom here like I do in 1 of the other ones that do work, but I don't see it.  Debug and physics variations have same results.  CPU Usage around 15% and GPU Usage around 50%. So something is doing work.  Am I not waiting long enough for this? 
* demo_bundled_physics_x64.exe  same as above. Doesn't seem to ever load/work?


* demo_gl_x64.exe has same start screen but loads up in about 5-10 seconds and appears to work 100% fine.
* demo_gl_physics_x64.exe works fine as well, basically same as other but with weird bouncy walking. 

* VoxelFarmDemoCellServer_x64.exe Appears to function correctly to the best of my knowledge. It's beyond me how to verify at my current knowledge, as IOClient and ThinClient can connect but no results in the client. I imagine there is another protocol at play here.


* VoxelFarmDemoClipmapMT_x64.exe  Appears to function correctly, generates the stats of the clipmapview object.   MultiThreaded and Single threaded variation works fine. 

* VoxelFarmDemoDBSimple_x64.exe Appears to function correctly.  Generates the DB and stresses it.  Gen: 20.891 s, 136MB written, 6 MB/sec throughput.  Read: 28.7s, 2678 MB read, 98MB/sec. 


* VoxelFarmDemoGeneratorServer_x64.exe Generates the mountain/tree terrain and I can connect/view with the ThinClient successfully.

* VoxelFarmDemoServer Able to successfully run, use the data generated by DBSimple and connect/query from IOClient.   *Suggestion*  the IOClient appears to not process newlines in its output? Perhaps add them? Additionally make the output more clear then rq and rc here. rq = Requesting CellID: and rc is response cell info and length? 


* VoxelFarmDemoSimple_x64.exe you are already aware of issue and is fixed in next version.

* IOClient and ThinClient were able to successfully be used with their respective servers. 




After having gone through everything, it appears like the only issue is with demo_bundled_x64 variations? 


0 0